Streaming live at 10am (PST)

Webflow Hosting + SSL = "too many redirections"


#1

http://lyfewellhyperbarics.com/conditions-that-can-benefit-from-hyperbaric-plus-treatment

non-www is already set as the default. Chrome gives a privacy warning before putting you into the redirect loop and Safari just gives up immediately.


#2

The error is coming from having the non-www set as the default. For some reason it is just kicking it back and forth. I removed the default setting on the non-www version and it is now working ok.

Now the remaining error is that the 301 redirect from the old site to the new one results in an error. Anybody know anything about that?

Go to lyfewell.com to experience the error for yourself. I suspect this has to do with how the 301 redirects are being setup, but I don’t know enough about it to say for sure.


#3

Hi @Cricitem

You are correct — the error is coming from having the root domain set as default. This is because most DNS providers don’t allow you to serve up your root domain over SSL hosting (this is known as CNAME flattening).

If you need to setup CNAME flattening I recommend checking out one of the following DNS providers:
http://www.dnsmadeeasy.com/
https://dnsimple.com/

If you’re not able to point your domain at a 3rd party DNS provider, then you will need to set your www version of your domain as your default domain. This will ensure your www subdomain is always preferred and the site will render as expected.

Hope this helps! :bowing_man:


#4

So… why does the Webflow hosting panel allow you to turn on SSL and set the non-www as the default if that is not possible with the suggested DNS configuration?

It isn’t the end of the world that both www and non-www will work, at least not as far as I know. I can’t think of how that would cause any issues. But it is strange that Webflow would allow a configuration that is guaranteed to break your site.


#5

But it is strange that Webflow would allow a configuration that is guaranteed to break your site.

I can definitely understand why this may seem strange in this particular instance, however this configuration does not always break a site. It only does if your DNS provider doesn’t offer CNAME flattening.

If you have a DNS provider that does allow for CNAME flattening, then the root domain will work perfectly with SSL hosting.

This is not a limitation of Webflow, but of DNS providers. Some do offer CNAME flattening, but most do not. The benefit of CNAME flattening is purely aesthetic — that is, if you want your site to appear as site.com vs www.site.com.


#6

Yeah I’m with you on all that. The old site used www so I’m content with just allowing that.

At this point, though, the redirect thing is an absolute mess. The home page works fine but subpages don’t and GoDaddy keeps on claiming that the issue is with the hosting provider, but they won’t say if it’s the hosting provider of the OLD site (some random company), or the NEW site (Webflow).

As far as I’m concerned, a redirect should be a redirect, and subpages shouldn’t be capable of completely bypassing a domain-level redirect. But I really don’t know enough about all of this to say anything for certain.

What I can say is, I hate GoDaddy with a passion and their customer service is beyond useless.


#7

Hi @Cricitem

It sounds like their may be another issue here outside of the SSL/root domain issue. I’ll send you DM with more details and we can troubleshoot the issue there :bowing_man:


#8

I’m having a similar issue.
It works fine in non-SSL but SSL with either default don’t work.
In one case (root ) I get too many redirection and when I setup the default to the www but still have problems @Brando
I’m getting two www for some reasons…


I’m using cloudflare as DNS provider.
Thanks for your help


#9

It looks like the site may still be propagating. To test this you can use https://www.whatsmydns.net/ to check the propagation status of your domains.

If you have SSL enabled, you should have the following DNS records:

2 A records:
@ → 34.193.69.252
@ → 34.193.204.92

1 CNAME record:
www → proxy-ssl.webflow.com

If you have SSL disabled, you should have the following DNS records:

2 A records:
@ → 23.235.33.229
@ → 104.156.81.229

1 CNAME record:
www → proxy.webflow.com

Please keep in mind that it can take several hours for the DNS changes to fully propagate.

​If after several hours you are still experiencing issues, please reach out to our support team directly and we’d be happy to investigate further.


#10

I’ve never understood why this is an issue in Webflow. I use services to host Wordpress sites and there isn’t ever a need to use a third party (paid service) to reroute/flatten. I’ve used a number of platforms other than Wordpress with built-in hosting and this isn’t an issue with them either. It’s an extra expense and headache when the Webflow hosting isn’t a discount service.

I couldn’t find it in the forums but I thought there were hints, over a year ago, that improvements were being made regarding this topic.


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.