Streaming live at 10am (PST)

Webflow issues with links after Export


#1

I have noticed that Webflow Exported Codes when it comes to links/href falls below standard and causing a lot of issue on my server.

Urls to webpage is expected to have a "/" before the name of the file. Webflow implementation is inconsistence and it is giving me hell on post export which I shouldn't have:

My Suggestion:

All export in the root should have a "/" e.g : href="/mypagelink.html" not href="mypagelink.html" or this href="mypagelink" as I found in the code generated by Webflow.


#2

Please I need support response. Please


#3

hi @topelovely, our export uses relative paths. If you want, you can set the BASE tag in your site hosting tab, which will set the url that the links on the page should be relative to.

You can also enter the direct path to the url in the URL field of link settings, by prefacing the slash in your link with a back-tick character when you enter the link in the URL field. This will allow you to put in any form of url there:

`/index.html

I hope that helps, if not, let me know and I am happy to further assist. Dave


#4

How do I use the `/index.html? Should I use directly? Because I tried and webflow threw some errors as invalid so how should it be used.


#5

Hi @topelovely, you indicated that Webflow threw some errors? Could you tell me what those were?

One correction I have, the /index.html should work even without the back-tick, I tested this and it worked fine and showed the correct path on export.


#6

Are you i can saying i can do this: http://mydomain.com/index.html? Would this mean that all links would have the forward slash ("/" e.g /contact.html ) before the name of the page instead of just page of the name or relative path ("../" e.g ../contact.html) ?

Kindly let me understand.


#7

Hi @topelovely, thanks for your question. Yes, if you enter the link as /page.html, it will also be exported with the slash, and not just index.html.

The export will look like: href="/index.html" and will look like that for whatever links you add the forward slash to. I hope this helps, let me know if any issues smile Cheers, Dave


#8

See the screenshot of web flow code:


I was expecting WF to have my style sheet link to be "/css/normalize.css" instead of "css/normalize.css"

I was expecting my href link to be "/oceanic-health.html" instead of "oceanic-health.html"

These are my issues. Which the base href hasn't resolved.


#9

Hi @topelovely, thanks for your update. I was looking at your site base tag and I would suggest the following setting:

Could try updating that, save changes and then re-export your site? With the base tag set, you would not use a slash before your links. All links on the page should be relative to the url specified in the base tag.

Could you try that and see if it helps ?

The other thing, if you do not use the base tag, then you would have to modify the paths to the css files and image files, those are also relative to the base tag url. I look forward to your result. Dave


#10