‚Ėľ
Streaming live at 10am (PST)

Webflow Login on selfhosted Website already not solved


#1

I have always this problem with the Webflow Code on a self-hosted Website. There is a webflow login on the bottom of the site. You can see it on the screenshot.

this is the adress of the self-hosted site: https://shop.regumed.de/

Here is my public share link: https://preview.webflow.com/preview/regumedde?preview=76f0477ddd2a74c6198a8b8a7b0651d1


#2

Hey @Bettina_Lucas,

How did you export your site ?

Can you please show entire url (i mean click on the url once first) from where the screenshot has been taken.

Can you please try it in incognito tab.

Thanks,


#3

Hi @Bettina_Lucas,

Can you please post the screenshot you are referring to?

‚ÄčThanks in advance, and I'm standing by for your reply.


#4

Hi @Bettina_Lucas, are you referring to this button:

if so, that looks like it is part of the symbol on the bottom of the page, it is not linked to anything, so you can probably remove that from the symbol and re-export.

Let me know if that helps


#5

This is the URL: https://shop.regumed.de/

It also comes in incognito tab.


#6

In the self-hosted site there is a link on this button. Here is the URL of my site:
https://shop.regumed.de/


#7


#8

The Webflow Login comes when i login in my self-hosted site as a user and want to edit there some personal data of my account.

This ist the URL: https://shop.regumed.de/
Please try this:
1. You can register and make a new account in the header with the button "Registrieren".
2. Then click on the button in the header "Ihr Kundenkonto" or "Anmelden"
3. Click on the Link "Adressbucheinträge anzeigen oder ändern"
4. Click on the button "Bearbeiten"

Then comes the Webflow Login.


#9

Hi @Bettina_Lucas

Thanks so much for bringing this to our attention!

I was able to reproduce the behavior and created a report for the team to investigate. We hope to have a resolution as soon as possible!


#11

Did you solve this bug? We need to finish our project and the error already exist. It is now over one month ago when i ask for a solution.

On the mobile device comes also an error message. I attached the screenshot.


#12

Hi @Bettina_Lucas

I have followed up with the team on this and we are currently still investigating the issue and hope to have it resolved for you soon.

‚ÄčThanks in advance for your patience and understanding with this.

I will post back here as soon as I have more information.


#13

Hello Brando,

we deleted this in your Webflow Code and than it works. But this can not
be a solution because we have to delete this in all our projects manually.

OLD CODE:

...
  if (/\.webflow\.io$/i.test(publishedDomain) && location.hostname !== publishedDomain) {
    doBranding = true;
  }

  if (doBranding) {
    var $branding = $('<div></div>');
    var $link = $('<a></a>');
    $link.attr('href', 'http://webflow.com?utm_campaign=brandjs');

    $branding.css({
      position: 'fixed',
      bottom: 0,
      right: 0,
      borderTopLeftRadius: '5px',
      backgroundColor: '#2b3239',
      padding: '8px 12px 5px 15px',
      fontFamily: 'Arial',
      fontSize: '10px',
      textTransform: 'uppercase',
      opacity: '0',
      transition: 'opacity 0.50s ease-in-out'
    });

    $link.css({color: '#AAADB0', textDecoration: 'none'});

    var $webflowLogo = $('<img>');
    $webflowLogo.attr('src', 'https://daks2k3a4ib2z.cloudfront.net/54153e6a3d25f2755b1f14ed/5445a4b1944ecdaa4d' +
        'f86d3e_subdomain-brand.svg');

    $webflowLogo.css({opacity: 0.9, width: '57px', verticalAlign: 'middle', paddingLeft: '4px', paddingBottom: '3px'});

    $branding.text('Built with');
    $branding.append($webflowLogo);
    $link.append($branding);

    $body.append($link);

    if (/PhantomJS/.test(window.navigator.userAgent)) {
      return;
    }

    $branding.css({opacity: '1.0'});
  }
};

// Export module
return api;
});

#14

Hi @Bettina_Lucas

Thanks so much for letting me know you found a solution.

Deleting the Editor code is a workaround, but we are still investigating a fix for this.

I will post back here when we have a permanent solution.


#15

Hi @Bettina_Lucas

Thanks so much for your patience on this.

Our team has pushed a fix that will disallow the Editor to function on exported sites.

‚ÄčPlease let me know if this solves the problem or if you see any other related behavior, please let us know.


#16

Hello Brando,

thanks for your mail. What i have to do now? Only to make a new export
and change the webflow.js?

Greetings,

Bettina Lucas


#17

Hey @Bettina_Lucas!

Yes, all you gotta do now is to re-export your website. It should no longer show the Editor panel on exported site :slight_smile:

Let us know if that works for you!
Cheers,
Bart

P.S. I've formatted slightly one of your messages so the code is colored and easier to read. Hope you don't mind :bow:


#18

Dear Bart,

thank you for your answer. We use Webflow as template for our
programming, so we just use parts of it, not as complete export.
Therefore my question again - the fix is just made in the webflow.js?

Best regards


#19

Yeap :slight_smile: If you export your website and get only the *.webflow.js file from the exported zip, you should be good to go :slight_smile: Let us know if you have any questions!

Cheers,
Bart


#20

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.