Streaming live at 10am (PST)

Webflow page wont loads - unpkg.com


#1

Hello Webflow Nation

I have been working on a website im responsible off. I have just pushed a new update and all hell seems to break loose.

When i try to open our site, it takes about 3-4 minutes for it to open and i can see waiting for “unpkg.com” at the bottom of the page in Chrome Browser. Pages loads after 4 minutes in chrome, but loads in Edge browser just fine. I already managed to fix all the content issues, but loading time are about to make me a victim of murder :frowning: if i dont fix this asap.

I tried to restore the site, and when i restored it most of my settings like reCAPTCHA key and similar stuff are gone and most the margins were all over the plane. I already got a call from our CEO who was pissed as he was in a meeting with new clients and our LP is having a party.

The second issue is im seeing a horizontal scrool bar at the bottom that wasnt there before and i dont have a clue why.

Im not the person who did the original site, but i totally redesigned it, as our CEO didnt want for me to do it from scratch, so i needed to crawl through all the garbage previous developers, some had 0 coding knowledge and 0 webflow experience.

Can someone help me understand what is happening and how to fix this.

!!!UPDATE!!!

I managed to find the culprit. I went into custom code section and found a script i removed and now page loads like it should.

I removed this script:

I dont have any idea what this script does, but i managed to google the author of the script, and it seems its some social icon releated stuff. So i decided to remove it. Page is so much faster now. I just home i didnt remove anything that i shouldt.

Thank you very much!


#2

Phew!! That was a dramatic read - glad you’ve fixed it!

Checking the custom code like you have done, and also using Chrome Dev Tools/Inspector to see what errors are showing are a great first stop when trying to diagnose what’s gone wrong :slightly_smiling_face: