Streaming live at 10am (PST)

Webflow Pages Plugin: Updating WordPress with New Collection and Page Made in Webflow

Got the static pages figured out. But the Collection pages rule has me stumped -


where do I create the page in WP? in the posts? Also I am testing this on a local machine will this be a problem for testing the dynamic content?

Basically what is the WP path i need to direct to the webflow people template that exists.
This is the individual people template for the dynamic collection.

thank you

It’s been awhile since I used this, but does it support mapping to posts? The plugin has “pages” in the name, so thought it was for mapping static content only.

If it does support mapping of dynamic content, my suggestion is to start by creating a custom post type that matches your Webflow collection names. This can be done either a plugin or by adding code to functions.php on your WordPress site.

Hi Colleen, thank you. I watched a youtube video by ran Segall of flux. It seemed to be able to map the dynamic content pages as well. In his video he didn’t seem to do anything special just named it the same in WP path as the webflow one. I’m wondering if it’s not working because I’m on a local machine testing it. @webdev any help on this? Mapping dynamic pages content with Webflow pages. I could try the Udesly adapter fully but for this use case it’s more work than is needed as it’s a temporary fix. The whole site is going to be rebuilt in Drupal eventually.

thanks
Jeremy

I just asked a question about the security of this plugin here because I feel that adding a 3rd party like this could add risks to the security of the site. Especially with how Wordpress works with updating plugins… huge pain.

@webdev Also, I have both a team plan and a business hosting plan on my site and still can’t get rid of the “made in Webflow” badge on the site that is hosted in Wordpress with this pages plugin… any other solutions for this? Thanks!

@bruh - If you have a paid hosting account and you set the display made in webflow badge to off, in project settings -> general then it should not render. At least this was the case on a test I performed.

@webdev so right thats what i did, and its still showing up:
image

@jbleroux

I tested with a local dev instance of WP and had no issue. Just follow the instructions in the plugin. Make sure you are running a current version of the plugin.

I just tested a page using a client site and a local dev instance and did not get the badge. You might need to refresh the plugin cache. Don’t know what to tell you if that does not work. I only use WP when I am forced to.

3 Likes