Streaming live at 10am (PST)

Webflow SEO Page Descriptions in Google

Hey,

Really hoping someone can help me here as this is starting to become a bit of a kicker for me for using Webflow over other website builders.

Nearly all my recent builds in Webflow are not displaying my desired/set page meta descriptions correctly for pages. They are often pulling through random icon/logo alt tags and filenames into the description, or just some random sentence from the page that doesn’t actually have much relevance to the page. See images below:

Now I know that Google are not obliged to use your set description and I have a read a number of Webflow forum discussions with people having this same issue.

This is starting to become such a problem where I may need to look at moving back across to Wordpress (even though I love building in Webflow).

Can anyone help me here? Am I doing something wrong somewhere? I haven’t had this issue when using Wordpress in the past.

Thanks in advance!

Alec

Hey Alec I saw you under the other thread where I posted I had the same issue.

Ours has just fixed but it took 48 hours. First off along as you’ve entered your title tag and meta description data on the page settings in Webflow the issue is on google’s side. You can also probably confirm this by checking how duckduckgo and bing are displaying your site.

Anyway here’s what we did to fix the issue.

  1. Make sure auto-generate site map is enabled in Webflow settings.
  2. Unpublish and republish Webflow Page
  3. Head over to google search console, sign up with the service if you haven’t already and validate your ownership of the domain
  4. Submit or Re-submit your site map in the sitemap section by adding https://your websiteurl/sitemap.xml
  5. (the important bit) you now need google to reinspect the homepage but don’t use the main inspect tool, this is what was causing the issue for us.
  • Wait for the submitted/resubmitted sitemap to show ‘success’ in green
  • Open it then click ‘See Index Coverage’
  • Click the ‘Valid’ filter to show the ‘Submitted and indexed’ option under the details overview underneath.
  • Once in here scroll down to the examples to list the pages that have been indexed, look for the homepage (it will most likely be the first link). Click it to open the side panel that slides in from the right.
  • Click ‘Inspect url’
  • Next to ‘Page changed?’ in the bottom right of the first card you’ll see ‘REQUEST INDEXING’. Click it and wait 48 hours your changes will go through.

We did use the request indexing feature on the main google search dashboard over a month ago (and it didn’t work), for some reason it would show the URL as ‘not crawled by google’ even though it had been. However, going through the sitemap to request indexing of the home page separately showed the homepage as being indexed (as it should… it’s in the sitemap after all!). I don’t know why this is. But I think it’s something to do with why the Homepages aren’t being crawled correctly by google.

Anyway google just being google I guess.

1 Like

Hey Elliot,

Thank you so much for your detailed response, I really appreciate it!

I will give your steps a go and let you know how I get on.

Thanks!

Alec