Streaming live at 10am (PST)

Website loading funny from Google SERPs

Hi guys I had this brought to my attention from a client and then under further investigation I have found it as an issue across all of our client sites on webflow.

The issue seems to only happen from the Google SERPs and only affects collection pages not normal pages. It also appears to only happen on iPhone not Android.

When clicking on the link from the Google SERPs the collection page renders outside the frame of the browser window. Scrolling left and up brings the website back into frame but you are still able to scroll right and see white space.

This does not happen though when navigating your way through the website to other collection pages. It only seems to happen on collection pages that you are brought to from Google SERPs.

I am worried that this is affecting my client’s conversion rates on mobile as the website looks broken.

Look forward to hearing your response
Regards,
Ben


https://preview.webflow.com/preview/static-electrics?utm_source=static-electrics&preview=3d99b34f4a12d896b8fa09f8a7f02195

Hi, @Ben-Probity! :wave:

First off, thank you so much for posting about the funny loading of your dynamic pages from Google SERPs. This definitely sounds odd.

The team was able to take a look at your project within Browserstack and noticed some similar results, and the issue may be related to the custom code added to the dynamic pages.

Would you be able to remove the custom code, republish, and note once the Google SERPs are updated if the issue resolves?

Hey Mistercreate,
Just for clarification you are wanting me to remove the coding from the custom code section within the page settings section? or are you meaning the HTML embed boxes located on the page iteself? I have removed the code from the former as the latter script is json schema.

Thank you for getting back to me on this issue

Hi @mistercreate, it has now been a fair while and I am sadly still experiencing the same issues as stated above. I am positive that Google has recrawled and reindexed my client’s site and no change. Are you and the team able to take a look from the webflow perspective?

Appreciation in advance,
Ben

Having the same issue on my mobile site…

On page load it seems to shift this text up, and when I scroll down, and back up, it’s fixed.
Same with my menu bar. When opened, it shifts pretty far down.

https://preview.webflow.com/preview/oneighty?utm_source=oneighty&preview=b5fd19f55f51448d9418691949b86078&mode=preview

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.