Streaming live at 10am (PST)

Website NOT showing up in Google and Search Console

Hi there,
Tim here, I recently finished my website and published it (imbalistudios.com), so far so good, but I can not see my site in Google. It simply does not show up. I do not get any spikes in Google Search Console, absolutely nothing. It says something with “no indexing” in robots.txt…where can I find that? Where can I change it? Please help!!


Here is my site Read-Only: https://preview.webflow.com/preview/imbali-studios?utm_medium=preview_link&utm_source=designer&utm_content=imbali-studios&preview=71d9e3c41deedf4c597d79fb45edd42e&mode=preview
(how to share your site Read-Only link)

Here is how to block search engines from indexing. You want the opposite. Make sure you did not enable these.

Hi there,
thanks for your help. It is still not working. Any other idea?

I just tested visiting your site and your published website is redirected to www.www.imbalistudios.com and then presents a SSL error. Check your DNS settings and resolve the issue first.

Hi Jeff,
Don’t know where the fault is.

Normally a CNAME record exists that points to a Webflow record. Review the guidance / instructions provided by Webflow that is linked on the project settings / hosting page.

My hosting provider doesn’t allow me create CNAME register. Here are my Indexing settings. Is this right?

You need to ensure you have your custom domain set up correctly. Google can’t index your site since it can’t access it. Note the setting of the default domain and the CNAME record settings. If your DNS provider won’t provide CNAME records then switch to one that is not broken.

See ->