Streaming live at 10am (PST)

Website not working in firefox

Hi all,

I’ve finally finished our company website, and everyone is super pleased with it, however I’ve had a couple of people tell me this morning that it “doesn’t work” in firefox.

The complaint from one of the guys was that the “projects” page didn’t load/display any projects, but everything else was fine.

So I installed Firefox to check out the issue and found that the site simply wouldn’t load AT ALL for me in Firefox, despite loading in IE/Edge/Chrome. Firefox also says that the site is unsecure. This is concerning because it could alienate a lot of potential clients.

Here is the link to my website:

and the read only

https://preview.webflow.com/preview/roberts-limbrick?utm_source=roberts-limbrick&preview=17cf1ed66cc0eb6e9c6cc667f77ae01f

Any help or insights into this are much appreciated.

solution for this topic

Two places/elements not loading correctly (Screenshot from chrome):
home
image

I solve this (By firefox inspector) & changing overflow:hidden to visible
image

Same idea her:
image

image

about & services works fine.

I dont know why - but 100% the overflow:hidden cause this bug.

Her its harder to debugg (only one row of images not loading)

1 Like

I can’t even get the page to load on Firefox. It comes up with “your connection is not secure”, so I have to force an exception to make it load… But even then it only loads text.

Clear cache.


Check this (Enbale SSL)

Anyway “on the way” i solve for you two mega bugs in your site layout (On firefox).

1 Like

I already have SSL enabled though…? It’s https on Edge/Chrome

Test your site on another laptop. Again for me the site works fine (Two versions of firefox) (So maybe this is Cache issue for you and for your client). Maybe other users can help you, sorry.

https://university.webflow.com/article/troubleshooting-website-security-issues#your-site-doesn’t-load-correctly-after-enabling-ssl

Also check other sites (Like Ebay or amazon) - maybe all sites on your laptop with this warning (Antivirus or any other issue).

Hey @Macker @Siton_Systems

This does seem weird, I don’t have the issue with the unsecure site, but I’m not seeing your Portfolio page unless I right-click and Inspect Element. (I just downloaded Firefox to test)

@Siton_Systems could you check this page and see if you’re seeing the collection lists on the portfolio page please https://www.robertslimbrick.com/tags/all

Empty.

without ovreflow:hidden;

I think it’s to do with the custom code for the masonry grid you’re using… :thinking: :eyes:

Thanks for clarifying Ezra :+1:

1 Like

Ah, that code is obsolete - I am no longer using a masonry grid. I should remove it I suppose!

Good catch @Siton_Systems

Remove the overflow on the collections and republish, removing unnecessary code will be good too.
Firefox isn’t my favourite browser! :grimacing: :crazy_face:

May be worth doing one at a time so you can find the culprit, it’s likely the display settings that Ezra mentioned.

I’ve done all the things you’ve listed (I THINK?) but it still doesn’t load for me at all.

Is it any better for you guys now?

@Macker - FYI: working here on current builds on both Win and OS X . It’s my fav browser. Faster and devtools rock.

Works in Firefox for me too. I think that’s just your cache acting up.

edit: not everywhere though. Projects pages show gaps between image rows, and sectors page won’t show hero images.

2 Likes

So I have a suspicion why those gaps might be appearing on the projects page.

Basically not every project has the full set of 10 images, so when there are fewer images set, certain sections are set to hide (filter > display if image X is set, etc). Though, this works just fine on other browsers and seems to be a fairly integral part of the webflow workflow. Not really sure if there’s a way around it that wouldn’t break the site?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.