β–Ό
Streaming live at 10am (PST)

Websites having issues with some interactions not firing in older browsers/devices


#1

Interactions are not firing on iOS7-9 on our site: www.thegoodkind.co

They worked fine before but now you can see on iPhone 5-6s+ that the images are not loading. The interactions work on every other device/platform.

This is due to the opacity interaction not firing which leaves the container as opacity: 0 and thus the images don't show up. (http://imgur.com/a/S9OPC)

We tried disabling any JS scripts one by one to see if they could be the culprit but to no avail.

I saw a couple of other posts with similar issues.. Does anyone know if this is a known issue with webflow currently?


ADMIN UPDATE: Changed title from "Interactions not firing on iOS7-9" to "Websites having issues with some interactions not firing in older browsers/devices" per some information from this post: https://forum.webflow.com/t/website-is-having-problems-with-interactions-and-nav-menu/39928?u=waldo
- @Waldo


Drop down menu not working in Safari
iOS 9 bug -- interactions not working
Multi-browser console error in webflow javascript breaks interactions, sliders "SyntaxError: unexpected keyword 'const'..."
Hamburger menu not working on Safari (MacOSX)
Website is having problems with interactions and Nav Menu
#2

I don't know if you noticed or not, but the interactions are not working on Safari version 9.0 either.


Multi-browser console error in webflow javascript breaks interactions, sliders "SyntaxError: unexpected keyword 'const'..."
#3

Have the same bug :frowning:


#4

I am having similar problems, take a look at my post, I dug deeper and found all the problems on where and where it does not work: https://forum.webflow.com/t/website-is-having-problems-with-interactions-and-dropdown-menu/39928

Hopefully we can find a solution to this.


#5

I have the same issue, interactions not firing at all


#6

Yes. Me too. WTF? This makes my home page pretty much empty on these devices.


#7

Yes I'm having same issues too. Most of my sites are hosted externally, so I've been able to troubleshoot a bot more. Issue raised by 'Matt50' looks like it could be the problem.

e.g. site created a month ago - code exported and hosted externally - no problem on iOS9 - drop-down mobile-menu works (javascript). Publish that same website with no changes to webflow staging domain drop-down mobile-menu doesn't work on iOS9. Export code again and upload to external testing domain - iOS9 problem repeated. Upload older webflow.js file - problem disappears.

Tested on iPad iOS9 9.3.5 and also tested on more of my sites using Browserstack iOS8 same problem and same troubleshooting solution.

Using Atom to compare old and new webflow.js files shows numerous changes, including the one that seems to be causing the problem (line 991-993)

// Determine if z-index should be managed
const zIndex = Number(data.el.css('z-index'));
data.manageZ = zIndex === defaultZIndex || zIndex === defaultZIndex + 1;.

when I removed just this line form the new webflow.js file the issue was resolved!

This needs urgent attetnion - there are still a lot of iOS9 devices out there - including one of my new clients I'm developing a site for!


#8

Yes, me too on my site Acquire.agency.

Not sure if it's related but the hamburger icon on those devices doesn't do anything either. Share link below in case it's a seperate issue.

https://preview.webflow.com/preview/acquireagency?preview=032a25d050d522e8afada72ad8378ddb

Thanks

Graham


#9

Thanks for the info @bryanH – I can confirm everything you've said!

I agree – this is actually the first time in years of working with webflow that I have questioned putting all my eggs in the webflow basket when it comes to hosting. I recognise problems will occur from time to time and generally, I have had nothing to complain about (usually the opposite in fact!), though when a client site gets broken for 3 days as a result of a JS file I have no control over (if webflow hosted) – it's worrying!

In my case I was just about to launch the site in question before the client reported problems in his version of safari (v9) so not such an issue – but, if I had published several sites that day before noticing or the bug being reported, it would be a big problem. I guess the only option would be to revert to a backup (which I haven't tested – do the webflow backups use whatever version of the webflow JS file was live at the time of backing up??).

Either way, if webflow's testing process doesn't include a thorough list of older browsers (I know my own list will be increased now) – I'm thinking in future I'd like to know when the JS file changes - perhaps a "since you've been gone" message to let us know and we should test functionality or proceed cautiously before publishing to the live domain?


#10

hi Matt

We need to file a bug report with all this info.
(I filed one yesterday before I troubleshot this a bit more and found error in new webflow.js file)

... and we can should email: support@webflow.com
(I'll do that shortly - but the more people raise this the sooner it might get fixed!)

Bryan


#11

Thanks for the link Bryan, I've filed a report.. let's hope it gets sorted in the next few hours.


#12

Hi,

While testing in browserstack for Safari 9 (EDIT – not just Safari 9 - see post from @Azfar_Chattha for full list of affected browsers) I get a console error (see screenshots attached):

"SyntaxError: Unexpected keyword 'const'. Const declarations are not supported in strict mode"

This results in the rest of the javascript file not loading, so sliders and interactions are not working in this browser. Note that this error does not happen in Safari 10 or Chrome (latest).

Of course, the reason this has come to my attention is my client is using Safari 9! ("Sod's Law" at work I believe).

The site is here: http://tenfold.webflow.io

Can anybody help?

(EDIT: I'm noticing a few similar forum posts at moment, has something changed in the webflow js file?)


#13

Getting the same error here but on iOS7-9.. at the same time iOS7-9 interactions have stopped firing.


#14

Yes I'm having same issues too.

(I've also posted this in reply to pascalT)

Most of my sites are hosted externally, so I've been able to troubleshoot a bit more.

e.g. site created a month ago - code exported and hosted externally - no problem on iOS9 - drop-down (hamburger) mobile-menu works (javascript). Publish that same website with no changes to webflow-staging-domain and drop-down mobile-menu doesn't work on iOS9. Export code again and upload to external testing domain - iOS9 problem repeated. Upload older webflow.js file - problem disappears.

Tested on iPad iOS9 9.3.5 and also tested on more of my sites using Browserstack iOS8 same problem and same troubleshooting solution.

Using Atom to compare old and new webflow.js files shows numerous changes, including the one that seems to be causing the problem (line 991-993)

// Determine if z-index should be managed
const zIndex = Number(data.el.css('z-index'));
data.manageZ = zIndex === defaultZIndex || zIndex === defaultZIndex + 1;.

When I removed just this line form the new webflow.js file the issue was resolved!

This needs urgent attention - there are still a lot of iOS9 devices out there - including one of my new clients I'm developing a site for!


#15

I have an older iPad I use for testing that uses iOS 9.3.5 and it was working fine displaying interactions until Friday 3/3/17. I've made some changes to a couple of sites I'm working on and when I published the pages with interactions like: slideshows, scroll to display elements, and element/menu slide-outs stopped working in iOS 9 on my iPad in Safari and Chrome. I was able to view the sites on new iPads and iPhones using iOS 10 and the interactions work fine. The desktop versions also work correctly in all current browsers like: Safari, Chrome, Firefox, and ie11 -- This just started recently when I published. On another site that I have not published the interactions work fine so I'm thinking something has changed when publishing.

Here are the sites to view the problem:
http://sd-emagazine.webflow.io/17-01/contents-january-2017
http://csnc-design.webflow.io

Interactions do work in iOS 8 on this site: csnc.webflow.io

Please help as these sites are going live by the end of March.


#16

Having similar issues on our site, image display interactions (fading in) are not firing on iOS7-iOS9 but works fine on iOS10.


#17

I am also having similar issues on my end for my website, the interactions make the whole page empty. www.metallum.ca


#18

Hi, I am having the same issues


#19

Same thing for me. This pretty makes my site unusable on devices with the older OS. My iPad2 is using iOS 9.3.5 and that appears to be the most recent iOS available for it.


#20

hi Matt

I guess the only option would be to revert to a backup (which I haven't
tested – do the webflow backups use whatever version of the webflow
JS file was live at the time of backing up??).

No luck there! I tried this yesterday. Duplicated a site and then reverted to a 1 month old backup - but problem persisted on webflow.io domain.

They need to acknowledge and then fix this problem ASAP.
Email them with the info - your discovery from browserstack seems to have hit the mark.

Good luck mate
Bryan