Streaming live at 10am (PST)

WEGLOT image problem

Hey guys, I’m building a site for a client, and we’re using Weglot to translate to different languages. Apparently, one image we need to translate (a different language image will replace the English version) is not working: because they say Webflow has several versions (resolutions) of the image, and Weglot cannot replace the images because of this.

The Weglot team show me this video with the problem. https://www.loom.com/share/

Any help is super helpful!


https://preview.webflow.com/preview/civalgo-v2?utm_medium=preview_link&utm_source=dashboard&utm_content=civalgo-v2&preview=c5b18bbee71cdc7982633ce6985388a5&mode=preview

Hii @Micheal_Beaulieu , I had the same problem.
A simple work around is to replace the image with HTML embed code and put image tag with source link of webflow uploads and then replace the link for translated version in weglot translations.
Now what happening is that image is not directly coming from webflow uploads (hence it dosenot have multiple resolutions).
just optimize your image and then upload.
hope this works for you.

Ohhhh ~ so, in the html embed, I would add:
Bob Face

and then style the embed code with the styles I wanted for the image, and that should allow me to add the translated image in Weglot?

Yup, once you have the image source link in html embed.
Weglot will pick it up and it will be shown under translations list in your weglot dashboard.
There you can replace the link for the translated version.

Weglot dashboard > translations

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.