Streaming live at 10am (PST)

Weird behavior on Mozilla Firefox

Hello,

I’m finishing a website for a client and I’m testing it on different browsers. I was scared that Mozilla would give me a hard time and I wasn’t wrong…

I have this weird padding/margin at the bottom of my page that I can’t get rid of.
I pretty much tried everything I could :

  • Delete the footer
  • Put a margin/padding, publish, remove the padding/margin, re-publish
  • and other small things that might have caused it

Please, I really need some help on this :grin: It’s really frustrating to finish a long project, test it only to stumble on such an issue :weary:

Any kind of advice would be greatly appreciated!

Walter

On Chrome

On Mozilla

On Designer

Are your screenshots from the preview, or from a staged site?

The screenshots are from the published site :relieved:

If you give me a read-only link for the editor and the published site link I can take a look

Here is the link. Sorry for the delay, I was away for a couple days.

I need a link to the published site as well so that I can compare the two in Firefox

Just as a quick tip, as long as the staging site has been published you can grab the live site subdomain from the read-only link right after the “/preview/” portion:

…/preview/princess-ka-dolls?utm_medium=preview_link&…

1 Like

I’m noticing you have two sections that are display: none—an empty “Div Block 40” and “Footer Mobile” (which seems to be unnecessary as appears to be the same as your “Footer Desktop”)—so I’d try completely removing both of these and republishing to see if that fixes the issue.

The issue is with the #YO element. Setting it to display:none fixes the issue. In the animation, when it is no longer supposed to be on screen have webflow set the display to none and it should work as intended.