Streaming live at 10am (PST)

Weird flickering issues on scroll in chrome


#1

View gif
website
editor link

Hi All,

I’m making this website and on scroll in chrome it has horrible white flickering background repeat load issues.

It doesn’t happen in editor (in chrome) and it doesn’t happen live on other browsers.

Does anyone know of a possible fix?

Thanks
Josh


#2

Hi Josh,

Nice hexagon grid.

I don’t reproduce what the gif shows on Chrome Mac. But I had that bug occasionally on some of my sites.


#3

Hi Vincent,

Thanks!

Ah ok, that’s reassuring. I’ll maybe reinstall chrome see if that fixes it for me then.

Cheers!


#4

Hmmmm, sadly thats not fixed it for me. I’m on the latest version of OSX too.


#5

What’s that site for? Is it a personal project to show your ingame photography ?

I wish I had the patience to play Assassin’s Creed… The last one I bought was the one with missions in Venice, but I couldn’t even play up to that because being fed up with stupid and endless side missions… Yesterday read about another version with missons at the Kheops pyramid, want to play those too :slight_smile:


#6

Hi, yeah just a personal fan site to show off some stitched together screenshots from the game.

I’ve played them all, they got more and more boring.

Fortunately this new one is a soft reboot of the franchise. Seriously recommend it. got rid of a lot of boring mission types. its now and rpg, so plays like witcher/skyrim. Really recommend it!

Just annoying re this flickering issue i have. only seems to be on this site :confused:


#7

I tried on chrome canary too, I have the bug, it’s discreet.

Not possible to reproduce on chrome normal though.


#8

Ah yeah, more discreet than mine. Odd then, maybe its something to do with my machine, but all other sites i’m on seem to not have the issue and this site didn’t either until a day or so ago.


#9

Can report i have the issue jsut as bad on canary, must be something off on my machine maybe :confused: :frowning:


#10

gone even more crazy now back on normal chrome haha


#11

the site also gets a great page load score so not sure why its happening


#12

@PixelGeek are you seeing this issue on your laptop? Sorry, appreciate any help i can get.

Also i made the background dark which make its less noticeable than the flashing white as its now flashing dark grey on scroll.

basically if you scroll all way to bottom, then quickly to top it has to basically reload the hero image and background repeat pattern giving this weird flashing/load issue


#13

Maybe try to clear cache (Sometimes this solves weird bugs).
https://support.google.com/accounts/answer/32050?co=GENIE.Platform%3DDesktop&hl=en

I am also dont see any bug (Chrome - last version)


#14

Thanks @Siton_Systems - I have reinstalled chrome completely, tried canary and still seeing the issue.

I’ve upgraded tot he latest osx on mac and still see issue.

I guess now its got to point where it must be my mac for some weird reason only. I guess just trying to rule it out that its only me, and its starting to sound like it is hahah. which I guess is good :slight_smile:


#15

Try to remove styles and/or elements one by one - and “find” what causes this problem. This is “how” computer works :slight_smile: (Backup before) - sometimes it could be some hidden div, or any tiny issue like this.


#16

Thanks, I think the cause might be all the hexagons in honesty. Its just odd as it was working fine for me a couple days ago even with them all there. I’ve only noticed this happening recently. it might be a limitation to the new interactions and having too many on a page, even though they are all called and completed separately.


#17

Again - remove the hexagons - and test. You use a lot of absolute position (I dont know why) in your design - maybe this is not animation issue but a bug with positions.

Add custom code:

html{
   background-color: red;
}

Now test - If the flickering looks red - your body BG cause some bug.


#18

Yeah, i’ve had to use the position css to move up the hexagons to align under the ones above. Although you’d think it could cope with about 10-15 rows move up a little as its quite a lightweight site.

Yes when I had the background colour set to white is when i could see the flickering issue, currently its dark grey and less noticeable as its close colour to background images.

I appreciate all your help :slight_smile:


#19

OK. Keep body and particles divs only. Than add empty div with the height of 1500px. Publish - test. If you see a bug this is something with your BG.

Also you can disable JS - and test this (Than it something with the animation)


#20

Thanks for this, will try this out once I get home and get back to ya :slight_smile: