Streaming live at 10am (PST)

What is the "Menu fills page height" option in Navbar Settings?


#1


What does the "menu fills page height" do? Cause it sure does not fill the page height stuck_out_tongue


#2

Hi @Hamzster, this option is used for the Navmenu when the Menu Type is set to Over Right (or Over Left).

This setting will force the Navmenu to fill the page from top to bottom in the current viewport (i.e. the visible area of the browser window):

I hope that helps, if you have some other question on this, feel free to ask smile

Cheers, Dave


#3

Haha I've never noticed this checkbox before today (:


#4

Ahhhh. Thanks! I always wondered what it did stuck_out_tongue


#5

Hi Cyberdave!
images links are broken, can you fix it ? I have difficulty to understand this option, maybee with pics it will be easier.
Thanks


#6

Hi @dam, thanks for the post. I have replaced those images smile Cheers, Dave


#7

I wish this setting was also available for drop down navbar. There are so many website out there that do this beautifully.


#8

@rafdesign, that sounds really interesting. Can you link to an example so I can look at what you mean exactly? :smile:


#9

Try the mobile version of apple.com! It's beautiful :smiley:

@rafdesign You can get the same effect by changing the height of the nav menu to 100vh.

David


#10

Thanks, I did and it works better.
I have been working over the weekend, trying to get an update to show the few problems. I will write back shortly to this post.


#11

when i have this unchecked, the "over right" nav menu still fills the page from top to bottom. is this a bug? because of a design problem or bug with the drop down-type menu, i might have to use the "over right" menu, but i do not want it to fill the entire vertical height of the screen. it's seemed to only do that, no matter if the checkmark is on or off.


#12

The checkbox doesn't give the menu its height, doesn't affect its dimensions. it's only here to tell Webflow that the menu fills the page and that the offset for scrolling to a section must be disabled.


#13