Streaming live at 10am (PST)

When posting on Facebook and other social media from Collection, no preview photo is showing up?

I don’t know if my question is on the correct category, - but I try here:

I have created a Collection with over 40 artists. But when I want to post someone of these artists on Facebook or others social media I got no preview of the photo of these artists. I have to go into Facebook for developer, for every single artist?? I have done 5 now, - but that can’t be correct to do that? It’s going to be too much work, because I have these artists pages in several languages, and they each have their own collection. Why does it work so bad to post on social media with collection, so they can’t see a preview of the post?
-I have noticed this before on other website which I have made with WF (have now made 4 website with FW). What should we do with this? Also, when our clients sit in Editor and post new items on Collection, and posting on Facebook and other social media, no preview photo of what they have done is in the post they want to post out.
Thanks a lot for your answer :smiling_face_with_three_hearts:

Hey @neanea6060,

So what you need to do is add some open graph meta tag to your template like this:

<meta property=”og:image” content=”http://www.yourdomain.com/image-name.jpg” />

This would go inside the the head section of the custom code in the template settings.

What I usually do for these, since facebook requires a specific size (1200x628px) I add an link cms item to the collection, then I pull in the link to the image from the CMS by using the + Add Field link.

That way you can add a custom image for each collection item :+1:

You’ll first need to add the image to the assets panel, then you can open the image in a new tab (using the angled arrow icon) and grab the link.

Hope this helps :slight_smile:

Hi ! Thank you for you answer.

I am confused?
Here where you type in the code: http://www.yourdomain.com, - I can’t link each and every post’s links code in here? there are over 80 posts in this collection, and every post has its own link?
So what link shall I put in there?

Please see printscreen: https://prnt.sc/rdox15 - Should I just get the "main domain in there? - or the domain with the artists?
Here is sharelink
Please help me :pray: :pray: :pray:
Thanks a lot :smiling_face_with_three_hearts: :heart_eyes:

Here’s a little video walkthrough. Hopefully this will be a little clearer :slight_smile:

Hi again! Thank you very much for your video! :smiling_face_with_three_hearts: :smiling_face_with_three_hearts:

  • Yes, I understand what you’re saying in the video.
    But my client has to come up with new posts himself, he can’t figure that out in the Editor?
    And I also see from your video that it says “webflow” in the provided linik, see print screen https://prnt.sc/rdx7xj
    I have not told my client I host with them.
    But , is there no easier way to do this? :pray: :pray: :pray:

Yeah the link says Webflow because it’s hosted in Webflow (by adding the image to the assets panel). You could host the images elsewhere if you that’s what you’re wanting to do, you’ll just need to add the link in the CMS.

To be honest I really have no experience with the editor, so I’m not 100% sure how you’d go about that with the editor.

If you want something a bit more dynamic (although more complex) you could use something like Placid to dynamically generate the social images. Here’s a post on that.

2 Likes

In the collection template settings, dynamically add the OG fields from your collection. No need for custom code https://university.webflow.com/article/open-graph-settings

1 Like