Streaming live at 10am (PST)

Where are the Paragraphs? Rich text is glued together

Hi all!

I’ve created a collection of blog posts, connected the text using a rich text field and added a class. Unfortunately, there’s just no option to create paragraphs.

The on-screen editor, removes the spaces after hitting save. The same thing happens with the backend CMS blog page.

The posts are located at Blogs > Read more

https://preview.webflow.com/preview/hubebub-d46d4a201608ce3b4d135bc3eae8b07?preview=21082f972290b64c2760739aa65fde69

What am I doing wrong? :sob:

Hi @kiki,
do you mean that you need spaces between paragraphs?

Hi @sabanna,

Yes, I can’t figure out how to do that. Is it possible?

Yes, it is.

Add rich text element to the site (do not connect to dynamic content), give it the same class that you have already and style its elements following this tutorial http://help.webflow.com/article/how-to-style-rich-text-elements

Feel free to ask if you still will be not able to get what you need.

Cheers

Basically, when you will style paragraph inside the rich text you can add top/bottom margins as much as you want.

I removed the dynamic link, created the selector for rich text. Where do I go from here?

The paragraphs show up now, but when I connect the text the block becomes un-editable.

I tried following the global selector but it gives me this error. I’m really confused.

All elements styling should be before you connect it to dynamic content.
I am usually just add one more rich text with the same class as my dynamic one, but do not connect 2nd rich text to dynamic collection. Then I am styling “static” rich text and it shows up on dynamic too.

1 Like

Thanks @sabanna. It’s a very backwards way of styling but I finally nailed it.

2 Likes