Streaming live at 10am (PST)

White Margin Issue - Live Site


#1

Hey guys--

Hope all is going well for everyone. I wanted to reach out to ask for some help with a margin issue I'm having when I scroll to the right of the page. There's this white margin that appears only when the site is live, but I can't seem to identify the issue in the editor.

I've never done anything differently than how I usually design my sites, which is odd. Also, if you scroll down you'll notice it readjusts and corrects itself towards the bottom of the main page. Tried searching the forum but couldn't find anything.

https://preview.webflow.com/preview/bluebrace?preview=305d3466e78f1eea996b162753af72bf

Let me know what you guys think! Appreciate the help.

Cheers,
JL


#2

Could you give a link to the live page?


#3

Sorry about that...


#4

Nevermind. I found it.

The problem is with your Column Fade Left interaction. The initial appearance has it offset to the right, which is why the issue is correcting itself when you scroll down (the column is being moved to the left, eliminating the margin).

To fix it, switch your Row 11 element overflow to hidden.


#5

The interaction issue definitely makes sense. Good call there! However, that fix wasn't able to correct the problem. I'm looking into a hidden element - sign up form - that used that fade left interaction to see if that's the root.

Any other suggestion?? Appreciate your help btw


#6

No problem!

Yeah I think I noticed that other element using the interaction as well. My suggestion would be to either simply place that element so it doesn't start off the screen, and/or set its initial appearance to display:none, so it doesn't stretch the screen to the side until called for, at which point it would automatically fix the mystery margin at the same time.

That second approach could give you some strange behavior on tablets, though. If it were me, I'd probably join the two and set it as display:none and also set it so its still contained within the display area. Setting things to transparent without setting them as display:none can also cause other undesired behavior like unclickable areas due to the transparent object.


#7

You're the best! Fixed it!!

Haha you have no idea how frustrating this was...

If you could confirm you're not seeing it anymore either that'd be awesome. Always here to help if you ever need anything.


#8

Ohhhhh I know EXACTLY how frustrating it was. That's why I try to help out with stuff like that as soon as I see it.

I don't see the extra margin anymore.


#9

Appreciate that!! Wish you the best

Cheers!


#10

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.