Streaming live at 10am (PST)

White space bottom of mobile published, not designer


#1

Hey guys,

My mobile (PORTRAIT) format is showing a big chunk of white at the bottom where there is still content on the published view, but everything looks ok in the designer both in preview and work mode. Thoughts? I tried different mobile browsers, tried messing with the body, background image, heights, etc. I'm sure it's a combo of these things that I'm missing. Thanks!

usercard.webflow.io to see on mobile

share link: https://preview.webflow.com/preview/usercard?preview=3bd392c948d2c2e86e49fa710962b8d6


#2

Hey @romanmg if you go through, you'll see that you need to set the background image to be set to Cover on all break points. It should be inheriting the style but it doesn't look like the background image set on the body element is carrying the "cover" setting for all the other breakpoints. So if you simply click on "body" go to the background on each breakpoint and click the cover button, that'll fix this issue.

At first the style will show in an orange color (the word "size"), when you click the cover icon again, the word "size" will show in blue and the white space will be eliminated. :smile:

Rather than using Margin bottom on your footer element I recommend using position and adding a bottom of 40px. Otherwise the margin can push past the parent element. :smile:

Please let me know if you have any questions. :smile:
Thank you,

Waldo


#3

White space removed! Thank you, @Waldo !

However now I've messed up the footer. It's overlapping the content above it. I did make the margin changes; right now it's at 0 px, but either at 0 or 40, it's still overlapping.


#4

I figured it out. I had to change the footer to a relative position and have a negative bottom. Not sure if this is the proper way, but it's the first thing that actually pushes the footer to where it needs to be.


#5

Hey @romanmg if you add 40px of padding to the bottom, and remove the bottom pixels, that should give you the desired style. :smile:


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.