Streaming live at 10am (PST)

Whitelabelling issue on Pro Plan

Hi !

I pay for pro version and i’m disappointed to see that its not really white label .

There webflow.com all over the code.

Well, since all assets are stored on WF servers and you use WF hosting there is hardly a way to not see paths leading to uploads-ssl.webflow.com in the code. :man_shrugging:

1 Like

Actually its very easy to have it replaced by a more anonymous domain name (alias) or use IP address instead.

I mean yeah, but what’s the point? I understand white labeling removing all the “built in WF” kind of messages, but these are just links to one or another hosting service which happened to be webflow’s. Not mocking or anything, just genuinely curious, why you want to hide all hints to webflow at all?

Hi Dram, what the point of removing “built in WF” in the other areas of the site then?

I mean this depends on what you want to achieve with white labeling in the end.

Hi Dram, There’s a difference between Custom Branding and white labeling. White label definition is:
A white label product is a product or service produced by one company (the producer) that other companies (the marketers) rebrand to make it appear as if they had made it.

In this case, if we find[ uploads-ssl.webflow.com] in the source code then its not something they can call white label.

Hi @Andrew ! can please someone look into this?

Thanks. I understand now your end goal. Yeah, I guess in this case the less webflow references the better.

Hi @TommyVirtuo

Unfortunately, this is a known limitation of the white-labelling feature and something our team is currently looking into. Hosting the images elsewhere is the only way to stop this currently, but of course this is a pain and not something a user should have to do.

I will add your comments to the existing issue for the team to read and post feedback here as we work on it.

(I’ve split the topic to make it it’s own issue)

1 Like

@TommyVirtuo
What happens when you put in custom code

=str.replace(“https://uploads-ssl.webflow.com/”, “https://52.85.138.244/”)

Basicially string replace all instances of uploads-ssl.webflow.com with domain IP

Hi @miekwave!

Isn’t a PHP function? I cant put this as is in my code ?

Hi Miekwave!

It does not work.

That might not be a good idea since, on the internet, because IP addresses can change.

Hi @webdev @TommyVirtuo @miekwave

We are pushing a new update soon that will make white-labeling also cover asset URLs. Instead of upploads-ssl.webflow.com/…, you will see website-files.com/

This should be live soon and if you are on the Pro or Team Plan your assets will be switched over to this new URL after a publish. :tada:

2 Likes

@Brando - That will be a very welcome addition. Great news!

1 Like

Hi all - following up on @Brando’s update last month, this fix is live: now when you enable whitelabeling for a site, your assets will live at a generic, unbranded URL (something like https://assets.website-files.com/randomfilename, instead of https://uploads-ssl.webflow.com/randomfilename).

For existing projects, be sure to republish that site to ensure your images serve at an unbranded URL.

1 Like

Confirmed Live! Thanks so much webflow! :raised_hands:

2 Likes

Quick question about the switch, does the former CDN path still render an asset after the switch? II just wanted to know in case HTML embeds referencing the old path would be affected.

does the former CDN path still render an asset after the switch?

Yep!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.