Streaming live at 10am (PST)

Why can't I see the attach a pdf in a post, when I am a PRO member?

Hi Webflow! I have attached a pdf in one of my blog posts, but I doesn’t see the pdf when I visiting the live site? why?
I am a Pro member and pay a lot every month , - so why can’t I attach a pdf?
This is what it looks like in the “collection field” where you see I have attached a pdf file.


Here is the blog post and you see that the pfd file is not here: (http://)https://lofti-63a58ad0294712dc740-826d804e09ca8.webflow.io/tours/jolaturur

Could you please help me?

Hello @neanea6060,

it is hard to speculate without a read only link, but the two questions that I have that might be responsable for your issue are:

  1. where you able to see it on a preview?
  2. did you connect your file field to link element?
1 Like

Oh, Sorry Pablo. I forgotten that!
Here is he sharelink

I look forward to hearing from you :heart_eyes:

Hello @neanea6060,

You have to add a link element to your page to connect it to your pdf. I was able to do it just by adding a button, but it could be any link element.
31%20AM
as you see on the picture above, if you add a button and click on the link settings you will be able to pull content from your collection list, in this case the file. I hope this helps, let me know if you have more questions.

1 Like

OK. I see! Thank you so much!
I have put a textlink. But would that say, - that I have to put a general text there (eg.: see file) , so when my client have to enclose a file, it would say for her “see file”?

No problem @neanea6060. You can have both a destination to the file and a name that you can pull from the collection list. For example if your client will upload a menu on a pdf format your link will have to pull the file to the menu and a title that says menu, you get both options from the link settings. I hope I’m being clear. Let me know if you have more questions.

1 Like

Thanks a lot Pablo!!
But I have another problem now, as I will change the text in the “textline” Webflow spell it wrong?
I have put a post here on Webflow to ask why? I think this is a new question, so I put a new post (I don’t know if I should have done that, or continue with you?)
here is the new post

Hello @neanea6060,

I’ve seen your new post, however I don’t have an answer for you on that topic. What I know is that webflow does not support multi language yet. It is on their wishlist and they keep saying it will come soon. What I can suggest you to do is to maybe instead of the text add an svg? I know that is more work and it will not be registered for the SEO but it will look the way you want. Maybe contact webflow directly and they can maybe give you a better answer. Good luck.

1 Like

But they also use this same apostrophe on a and i in France and other language? So that is very strange? I had the same issue when I should do a Rich text in a Collection. There i could not use apostrophe at all. But they fix it.
But now it is a textlink? So maybe it is only the textlink which is wrong with them. But then other language which have apostrophe (as France) can’t use it ?

@neanea6060 maybe it is the way all you links are styled. Let me take a look, is it on the same page as your original post?

@neanea6060 is this how it is supposed to look?
08%20PM

1 Like

Yes. Correct :smiling_face_with_three_hearts:

yes. Her is a sharelink

@neanea6060 try this, select the correct form of your text from a text editor or from here even, and copy it, then on your link text delete what you have a paste the correct form, that is what i did above.

1 Like

you’re just absolutely amazing. It worked!!! Jubiii! :smiling_face_with_three_hearts::smiling_face_with_three_hearts:
Should I then delete the second post? (don’t know how to do that)

But wait…
Now this “textlink” is in every post, although I had only put a PDF one of the posts? why does this happen?
Because I also have put a Video in one post, and this video are only showing up in this post, not the others. So I thought this would be the same with the pdf textlink. So how to solve this??
see sharelink

Here is also a video

Awesome @neanea6060, I’m so glad i was able to help you. Im sure if you look you will see the option to delete the other post, it is probably on the three dots next to the hearth on the bottom of each post, maybe? Also, do you mind marking this post as solved, that way if someone else has the same issue they can reference to this post. I just saw you new issue. So, all collection items look the same by default but you can style them to hide them. for example you used a div block to add the text link right? add a combo class and hide it from the page like this
42%20PM
you will have to do it on every page that you don’t have a pdf to show. Let me know how it goes.

1 Like

Thanks a lot Pablo!
Would that say, that If my client have to do a new post, without pdf-fil, she have to contact me to hide the textlink in that post? I don’t hope that is correct, - or?

@neanea6060 I will have to get back to you later, I have to step out of my computer right now. There is a way around it though don’t worry I will just have to look at your site a little longer. Talk to you later.

1 Like

Fantastic!
You are awsome :heart_eyes::smiling_face_with_three_hearts::blush:
I will wait until you have time for me again