Streaming live at 10am (PST)

Why Does My NavBar DropDown Element Need Right Margin of -4px?


#1

בס"ד

Websites discussed:
http://leavesofmedicine.webflow.com
http://www.leavesofmedicine.com

Share Link
https://preview.webflow.com/preview/leavesofmedicine?preview=f1b98420e89d6ab4b85e0c6766dac39e

My NavBar Dropdown elements for some reason create a gap of 4px on the right:

If I set the right margin of the DropDown Element to -4, it looks alright:

When I export my code and upload it to my web host (iPage), it again comes out with that 4px margin:

If I adjust my right margin to -8, it comes out good on my web host.

Can anyone explain why this is, and how I can solve it in a better way?

Thanks

Yoram


#2

It's because the upper element, the widget container itself, has a 4px margin.

See : https://v.usetapes.com/ZQgd3yCJAs


#3

Thanks. That works great smile


#4

Hello Again

I thought it worked....
I removed the 4px margian from the DropDown Container like you demonstrated on the video, but when I exported the code and uploaded it to my web host, it still had a gap of 4px after the dropdown element.
I then added a -4px margin to the dropdown container and that fixed it...
It works, but I'm still confused as to why I need that...
Regards
Yoram


#5

can you give me publink link + published link again?


#6

Hello

published links:
leavesofmedicine.webflow.com
www.leavesofmedicine.com

publink:
https://preview.webflow.com/preview/leavesofmedicine?preview=f1b98420e89d6ab4b85e0c6766dac39e


I am also having trouble with the SEO. It is in Hebrew, and when I search for a few of the key words on google, the webflow version shows up with some weird text:

However, www.leavesofmedicine.com (which is the real domain of the site) does not show up.
I then searched for www.leavesofmedicine.com on google and noticed that the description came out wierder:


When I checked the SEO of the source code that I exported, it seemed fine.
Do I need to add some code that specifies that it's in Hebrew or something?

Thanks for your time

Yoram


#7

you have try to re save re export and re upload the code right?


#8

BS"D
Yes, I did that...
But that is my little problem. I would love to find out why the SEO isn't working as I expected


#9

Hi @yoramraz1, thanks for the info. I can see your site looks like it is hosted on another server? If so, I would do two things:

a. unpublish the leavesofmedicine.webflow.io domain (it is currently published) and B. Submit your own sitemap to google for leavesofmedicine.com to google. That will help to get your site indexed correctly.

Also, now is a good time to think about hosting your site in Webflow, with our new Fastly integration, sites are now up to 10 times faster using Webflow hosting, and probably one of the fastest hosting platforms now on the planet smile

Cheers, Dave


#10