Streaming live at 10am (PST)

Why does site search return no results

Hi I’m not sure what I’m doing wrong, but when I use the site search I get no results. I have a CMS collection with some data entered so shouldn’t it be searching this? When I type in a search with a word that’s in one of the fields in one of my CMS entries it doesn’t display anything. Shouldn’t it display the entry?

I’ve made sure the box isn’t ticked to exclude the collection from site search results.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey @cmla,

You will need to add CMS hosting to your project in order to see actual results.

See details here

Until then you will be able to see the sample results and style these.

Hope that helps to clarify it.

Thanks,

Tom

Thanks for your reply Thomas,

It says under the hosting tab that “This project currently has CMS Hosting.” I purchased the CMS plan.

Note: Indexing is not instant. These are common gotchas…

Creating an index

Once you’ve added CMS or Business hosting, your search index is created after you publish your site for the first time.

You can design your search results before your index is created (or before you add hosting) by working with our sample results.

Updating your index

There are two ways to update your index so the content in search results matches the latest updates to your site content:

  1. Manual reindexing
  2. Automatic reindexing

On CMS hosting, manual reindexing is available once every 24 hours. On Business hosting, manual reindexing is available once every hour. On CMS hosting, automatic reindexing takes place once every 72 hours, and on Business hosting automatic reindexing takes place every 12 hours.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.