Streaming live at 10am (PST)

Why is google not showing my title tags/meta description

This is what I put in but it is not showing up on Google, I have no idea what to do! I have taken down the page and reposted it a few times. I have deleted my cache. I do not see anything on the forums to help. The picture below is what is actually showing up

Please help me solve this problem. I do not know what to do. I have two published sites with webflow and I am running into the same problem for both of them… the only thing I can think of is the site map being wrong? But I do not know how to make one I used webflow to make it for me.

If you launched your site before your HTML titles and meta-descriptions were complete, Google could have indexed what was there. You should be using the Google search console where you can test as Google and see what It sees. If the information is stale you may be forced to wait until Google re-crawls the pages.

Hi @Liam_Ferguson,

On the google search page results, the first title name, click the little 3 dots next to the site name title. It will give a date when the site was “first indexed by Google”. This can take a little time to adjust.

If you want it to adjust quicker, that can be complex. I would change the “Title Tag” in a small way. Like add another word at the end, then republish. Then go delete the word and republish the correct title and descriptions. Wait a while for the re-index to occur.

All this can take a few days overall. If time is important, you’ll need to ask Google to re-index:

https://search.google.com/search-console/welcome?action=inspect

https://support.google.com/webmasters/answer/9128668?hl=en&visit_id=637481520183407180-85815048&rd=2