Streaming live at 10am (PST)

Why is my anchor link scrolling to the top?

I have an anchor link set up on my page (Features button on the header). When I click the link the section scrolls all the way to the top of the page rather than the bottom of my nav bar, how do I fix this? (In a non hacky way like adding an anchor element the same size as my nav, like I have done in the past)


Here is my site Read-Only: LINK

@peej I had a look at the page, could you clarify what it is that you want to achieve? When I click that ‘features’ button, it scrolls to the ‘features’ section. Is that not the behaviour you want to see?

Hey @sarahfrison
The issue is that the anchor seems to go all the way to the top of the viewport, so my section gets partially hidden behind my nav. I’ve actually had this problem on all my sites.
I would like for the top of the section to go only to the bottom of the nav.

What I see:

What it should look like:

See getting-webflows-smooth-scroll-script-to-align-correctly-with-fixed-headers-navigation

Under element settings in the right sidebar, simply change the element tag of “Navigation Wrap” to a Header (currently it’s a div).

I tested this in your project share link and it works correctly.

1 Like

Interesting, I was convinced it would automatically scroll to the bottom of the first position: fixed; element.

Thanks for the fix!

No problem, glad I could help!

Samuel Liew
http://webflowexpert.com

yay, glad the issue was solved :slight_smile: