â–Ľ
Streaming live at 10am (PST)

Why is my section won't fit when the element is longer? Grid Help


#1

This happened few times when I worked on other page and came back.
How can I fix this situation? Thanks a lot!


Here is my site Read-Only: LINK
([how to share your site Read-Only link][2])

[2]: https://university.webflow.com/article/sharing-your-sites-read-only-link


#2

I thought I fixed the problem, but it’s still like this on the mobile view…):


#3

Did you fix it? Looks like it… unless Im missing something lol.


#4

Sadly no, I wasn’t able to fix it :sob: now it’s doing that on mobile landscape & portrait view. Do you know how to fix it @J_Canan?


#5

Ok, what page am I suppose to be looking at?


#6

It’s on my homepage. if you change the view to mobile landscape, you will see the cut off. If you change to portrait, you will see the gap before footer. Thanks for looking at it!


#7

Ok, give me a min to look at it.


#8

So there seems to be a whole lot of things going on here which kind of baffle me as far as sizing choices and how you have certain things stacked inside of each other. Maybe @matthewpmunger can see something I can’t.

Video of my thoughts: https://cl.ly/50fabb90019b

Just from my perspective I would suggest starting over with a new clean section while keeping simplicity in mind as far as architecture for your site goes. As I mentioned in the video, the more complex you make something when it doesn’t necessarily have to be the more problems you will probably face in the future like you’re experiencing.

Last note: what might also help is to keep all that content in one grid instead of having two different sections with two different grids. No need for two different sections.


#9

Thank you so much for taking a time to make a video @J_Canan! I just started using webflow a week ago, so the tool is super confusing for me… I’ll try to re-create it but not sure how I would simplify it :sweat_smile: There was some stuff you mentioned that I didn’t know so I’ll try your method. Thanks a lot for the tip!

oh also, I couldn’t figure out how to put subtitle in a black box, so I created a button without a link. please lmk if you have a better way!


#10

@J_Canan I was cleaning & deleting some stuff and it just fixed the overlapping thing!!! :partying_face:


#11

See man, that’s awesome news!! Good job! Simplify simplify simplify!

Here is a video showing how you can achieve that button effect without using a button. :slight_smile:

https://cl.ly/ae11bf7dd90e


#12

Oh smart! Don’t know why I didn’t think about this way. Thanks a lot for your help :grinning:


#13

Haha, that’s alright! And no worries! Reach out anytime! Happy Webflowing! :call_me_hand:t3: