Streaming live at 10am (PST)

Width of site wider than site


#1

I know someone has answered this before

... and I use to know how to fix this...

I set the body of site in yellow to show width of site.

Scrolling right will show the yellow margin that's not suppose to be there.

Not sure why it is doing this.

see video

http://quick.as/0OB3Fjd8


#2

Would you mind posting a public link to your site?


#3

Check to see if have anything that contains text that runs over into the right margin. I have only had that happen on the smaller media queries when text overflows width.


#4

Most likely you have an interaction that brings elements in the page below... and while waiting to come into the page, they stay outside and enlarge the body.

OR

you have one element too big below.

Anyway, select your sections one by one and set them to overflow:hidden to mask what's outside, see i it solves anything.

Can you please share your project’s public link so it's easier to understand your issue?

Learn how to do it here: http://help.webflow.com/sharing-your-public-webflow-site-link


#5

This one is very difficult to replicate... but I've think found it.

Basically... when an element scrolls in from the right
--- and the page width is "narrow enough
----- you get the "border beyond" the frame.

If you turn transition off... the problem goes away.

Will try the overflow thing.

EDIT: Overflow:Hidden didn't solve it
EDIT2: hold on... might be there... testing it


#6

See Video... what I did / what I am going

scroll up and down page while "right scrolling (mac mouse)"
so that you scroll left / right at the same time.
As the transitions take effect... you will see the "yellow" appear.
Yellow is the background color of the body... to test.

See Video
http://quick.as/lX1oTDpo

Public Link
https://webflow.com/design/ocasio?preview=d28ec0501800b8735c5927fbc705838a


#7

Select section ServiceArea, remove the map entrance interaction. Select the container in it, affect it the map entrance interaction. Be sure the section has overflow:hidden.

So in the future don't affect your interactions to the outer section, so the overflow hidden can apply to everything inside.


#8

And always post your public link, you'd have had your answer 20 hours ago ◕‿◕


#9

that didn't fix it frowning

see video
http://quick.as/j2O3U7WP

and if you notice... the Map Pin issues came back also.
Earlier, I said the Pin issue fixed itself. But pin now clearly says "Service" not "Service Area".
If you click on the word service and scroll up / down - you will see "Area".


#10

That totally fixes it!

You forgot to also remove the interaction from the section. It's still attached when I follow your pub link. And when I remove it it fixes the bug.


#11

you're right. I didn't see the interaction on the section.

Thanks smile

Did you notice the Map Pin ?... does it say "Service" on your computer ? or "Service Area"


#12

Both with an elevator cursor (:

http://cl.ly/image/3a3f3W333Y0i


#13

Why does it do that ?
I've been able to replicate this on different computers
and different projects ?

This morning... the problem "seemed" to have gone away.

Then I realized it hadn't frowning

@thesergie - can you look at this please ?


#14

thanks for the help Vincent smile


#15

it does that on my maps too, must be a bug.


#16