Streaming live at 10am (PST)

Zapier and Webflow Validation Errors

Hello,

I’m attempting to connect Zapier and Firebase with Webflow CMS. I had the connection working fine earlier, and when I come back to add more fields through Zapier for the new CMS fields I setup, I cannot avoid the “ValidationError: Validation Failure” error. I’ve tested literally every field individually and it continues to give me errors, even though testing with the base name field only (something that was working earlier today) fails to work. I’ve also tested each field manually through the Webflow CMS and it works perfectly, so I’m fairly confident that it has something to do with the Webflow API that connects Zapier and Webflow CMS.

Any thoughts on how to fix these issues? The possibilities provided with Zapier and Webflow is a major reason why our team migrated to Webflow, so any help is very appreciated.


Here is my public share link: LINK
(how to access public share link)

That usually happens for me when a either a required field within the Webflow CMS is not populated from a Zapier zap, and/or if I don’t set the “archive” and “draft” bits on the zap.

Thanks for the help! I actually figured out how to fix the validation issues: Any change you make to the website (including non-frontend CMS changes) you MUST publish. Then, refresh the Zapier page and fields and retry it. That’s what’s worked for me and I didn’t find anything anywhere saying that that’s an issue. This includes even if you “save changes” to the CMS. You still have to republish the website.

Hopefully this helps someone else.

Yep. That’s an issue too :scream: There seem to be a ton of little gotcha’s.

Another one that I LOVE (e.g. hate) is if you are triggering your Zapier zap on form submissions, you have to Publish your site and fill out the form FIRST or Zapier will never see it.

:clap: