Streaming live at 10am (PST)

Certain elements in not showing on mobile

Certain elements are not showing when I open my published site on a mobile device. I am using a Galaxy S8.

See below for the project (read-only) link and the elements and sections that are not showing on mobile.

I tried to troubleshoot the problem by changing layout and positioning options but was unsuccessful.

Web Design Section (Home Page) - It looks like this:

But it looks like this:

This happens in other places of the site as well:

Here is my site Read-Only: https://preview.webflow.com/preview/nicolass-first-project-bbd691?utm_medium=preview_link&utm_source=designer&utm_content=nicolass-first-project-bbd691&preview=ec87274fd1aedfd6ff85479dcf24cde6&mode=preview

Hi Nick,

Can you share the published site?

Sure thing! You can find it here: https://nicolass-first-project-bbd691.webflow.io/

Hi, @nick_passaro!

Ben here with the Webflow Customer Support Team!

Thanks so much for reporting this issue that you’re seeing. I did some testing and I think I’ve spotted the issue. It looks like this is a bug.

I reported this to the team and they’re working on it now. I can’t provide a timeline for when a fix will be available, but someone from the team will reach back out as soon as we know more.

In the meantime, the issue seems to be coming from the on scroll interaction. As a workaround, you can do one of three things.

  • First, you could change the interaction so that it triggers on all breakpoints and not just on the desktop.
  • Second, you could remove the interaction altogether.
  • Third, you could rebuild the on-scroll interaction.

I know none of these are ideal and I’m so sorry for any inconvenience this may be causing.

Let me know if you have any other questions and I’ll be happy to assist you further!

1 Like

Wondering if this been resolved? I’m getting the same issue, I think. I have all my interactions set up, and on mobile there’s only one element that won’t show at all. It’s showing up fine in the mobile preview while on desktop.

I’ve tried disabling the interactions on mobile, and the element still won’t show.

Read only: https://preview.webflow.com/preview/alexs-first-project-330803?utm_medium=preview_link&utm_source=dashboard&utm_content=alexs-first-project-330803&preview=ab8a3006829011d274ad3457dd1b73fc&mode=preview

I fixed my issue — just toggled the display settings for the element to ‘none’, published, then toggled back to visible.

1 Like

Hi, @nick_passaro!

One of our awesome engineers was able to run down what was happening here.

To fix this, you’ll need to open this project up in the Designer. And then you’re going to need to open up the console. Once there you’ll need to paste the following code into the console and then press enter:

_webflow.dispatch({
  type: 'IX2_UI_INTERACTION_ITEM_TRASH_ICON_CLICKED',
  payload: {
    interaction: _webflow.state.IX2UiStore.interactions.find(
      i => i.id === 'i-25'
    ),
  },
}); 

Here’s a quick GIF of how to do this.

Once you hit enter, you’ll need to save your project (CMD + S on Mac, CTRL + S on Windows) and then republish.

Can you try that and let me know if it resolves your issue? :webflow_heart: