Streaming live at 10am (PST)

Flexbox styling not rendering on iOS


#1

I’ve got everything looking good in Webflow on vertical mobile, but when I load it on my actual phone, the Wrap Children doesn’t seem to be working.

Here’s Webflow:

And here’s a screenshot from my phone:

Is this a bug or have I just screwed something up?

Here’s my share link: https://preview.webflow.com/preview/swiftv3?preview=92568859792a72880a71bfe484bb8aee

Any help would be greatly appreciated!

Chris


#3

recreate each section for each device using display setting in the visable on section


#4

@cyberdave Thanks for the help over email. Troubleshooting this now.

I’m switching those flex basis percentages over to widths now. What should I set the Flex Item to? Shrink if Needed, Expand, Don’t Shrink or Custom?

Thanks!


#5

Hi @Chris_Scott, I would not make any setting override to the flex item, the overrides for flex item on all classes for flexbox small and flexbox large should be removed, then set the width of the flexbox small and flexbox large classes to 50% width.

I can help to take another look once those changes are made. Hang in there, trying to get certain flexbox styles rendering on safari as you expect can can sometimes be tricky.


#6

Thanks for the help, Dave! It’s up and running now, just had to set those widths rather than relying on the flex item override, as you suggested.

Appreciate the help!

The finished project is live (and sexy) at http://swiftgalleries.com.

Chris


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.