Streaming live at 10am (PST)

[FOUND] Issue with Interface "Remembering" the past


#1

Something weird has been happening recently.

The system sometimes "remembers" old settings... and re-implements them with the click of a mouse.

For example: (and this just happened but I cannot replicate it yet)...

I had a gradient background on a section about 30 minutes ago.

I changed the background to black (000) and continued working.

When I selected my "Header Section"... the application "remembered my old gradient setting" - and removed the newer black background color with the old gradient value.

I've seen a similar issue - when clicking on a section - all the sudden, the section will "jump to an old location". For example if an "old" vertical position was set too 200.... and the "newer" position is 210 - sometimes... clicking on that specific section will make the section "jump" by updating the vertical position to 200.

[EDIT:] See Note Below [END-EDIT]
I've also seen... a specific section will "all-the-sudden" duplicate itself. For example: you have a section named "sec_Hero" - without copying the section - a new section is created with the same name - but it's settings can be updated without the affecting "the original" section. Keep in mind - both sections have the same class name ??????? Deleting the duplicate section works - and doesn't affect the original section.

I saw this last issue happen several times yesterday... I thought I was going crazy.

And it happen again - today - on a NEW PROJECT - twice. That's what prompted me to post this.

Something smells rotten in Denmark. Please have the cook look at the recipe.

[EDIT:] In reviewing the project further - I actually hid the gradient... did not remove / delete it. Then I added a black background. This "issue" didn't remove the background as I thought... it re-enabled the gradient - thus over-riding the background that's still there.[END-EDIT]

[EDIT2:] I also noticed... when this occurred... another change that made - was re-implemented ON A DIFFERENT ELEMENT. I had a click-to-section on a link. The click scrolled down to another section. I removed / changed this in the section list by selecting "choose a section". When this issue happened - it "re-added" my click-to-section value. It also changed the vertical position of ANOTHER DIV to an old value. The application "is remembering old values".[END-EDIT2]


#2

and it just did it again.

will exit the application and browser - go back in to see if it continues.

This is frustrating.

[EDIT:] Back-in. Apparently, when you assign a jump-to-section value to a link - if can not be removed. You have to delete the original link.[END-EDIT]

[EDIT2:] If you rename an section - ie: Section to Section-New... the Old Section name is still available where-ever you can an element name (such as affecting a different element in transactions). Also,the new element name is not available until you Clean-Up the Styles - AND exit the designer - at least to the Desktop level. [END-EDIT2]


#3

FOUND IT

This screen will show what happens with Sections.
It doesn't just happen with Sections though.
I've encountered the same problem with several other elements.

Summary: 2 Proof Positives
1) Show Header with Gradient
2) Show Designer Background Value
3) Hide Gradient
4) Preview Site
5) Exit Preview
6) Navigate tree to Header section and Click = ISSUE

7) Repeat Steps 1 through 5
8) Click on Header section = ISSUE

http://quick.as/O4zoC0m1


#4

Hi @Revolution, I am taking a look into this... will get back once have some info on it.

Cheers, Dave


#5

#6