Streaming live at 10am (PST)

Problem with in-page linking


#1

Hi. Got this issue: I'm making a 1-page site which mainly is based on interactions, but also I was thinking of utilising in-page linking. Actually, the linking is inside a single section. So there is a div in this section which is a menu, and there is a div which holds the contents that have IDs to which the menu in the div points. But the page does not scroll to the ID. Can you give recommendations?
Thank you.
The page is https://preview.webflow.com/preview/eviro?preview=e863e577b22019fd37d83e191afe87e9
You should press the top left part of the stylised leaf to go to the part of the page I am talking about.


Here is my public share link: http://eviro.webflow.io/
(how to access public share link)


#2

...> Here is my public share link: http://eviro.webflow.io/

This is not your public share link, its the url ...
See here:


#3

Oh, I see
https://preview.webflow.com/preview/eviro?preview=e863e577b22019fd37d83e191afe87e9
This is the right one, I guess


#4

Exactly. Perfect! Thanks


#5

Holy mate, this is quite ... unclear ...
The only thing i can tell you is maybe to overthing your overall html structure. Its way too confusing.
But to be honest, I m not sure what exactly the problem is because there is so much going on.

From what I can tell you is that there are two elements that are set to "pos. fixed".
And because the content is fixed I m thinking that it prevents the scrolling in-page linking from working.

If you change "Part1_sect" to auto instead of being fixed it will then work. But it will change the whole look of your site.

What i did:

  1. Remove all Interactions (hidden and whatever)
  2. set "Part1_sect" to "auto"
  3. Give "Part1_content" a top-margin of e.g. 10%.

Then you ll see that it will work.

Because the whole container, holding all content, is fixed it wont scroll.


#6

You were right, mate. Did not work because of having the section position placed to fixed. Thanx. Yep, the whole layout is ruined now, but I'll try to think of something or maybe I'll try the tabbed thingy, rather than the scroll thingy. Thank you, again.
And would you happen to know how to force the figures to hold the form? When I resize the window the "flower" changes the form. Is there a way to keep the proportions of the elements?


#7

The Overall-Div that holds the logo itself has an % based width and height.
Since both values are not equal, but 40% width and 77% height it all other % based values are based upon that. So there is always a wrong proportion.


#8

No. I think, you did not get it. Look, I've set it to 50 and 50% now, nothing changed. Actually, I know the reason - it's because I have the logo elements (5 parts), set at the background. If I set them as an image, and set width to auto, everuthing will be fine.But then I have no idea how to manage the appearing background image and the text placeholder.


#9

hm i see your point. but well i m out at this point.
maybe there is someone else here that might help you with that problem.

does it really need to be that .. well .. complex?
maybe there is another solution that will have the same outcome, but has a much more
flexible and stable structure?


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.