Streaming live at 10am (PST)

Site Not Rendering The Same In All Browsers

We designed this site from the Alpha Template in the Chrome browser. However, when we inspect the site in Safari and Firefox the site is not looking like it does when opened in Chrome. If someone would kindly explain to us how to fix this issue, we would appreciate it. Please find attached photographs the site view in Firefox and Safari.


Here is my site Read-Only:
https://preview.webflow.com/preview/deft-ux-design?utm_medium=preview_link&utm_source=designer&utm_content=deft-ux-design&preview=dd1ea536d47b89511992ab9809c8b8d9&mode=preview

The way you’ve gone about constructing the header elements within the Sticky Menu symbol seem to be the problem which is affecting how each browser interprets the elements.

This video should explain what I’m thinking will fix the problem and hopefully it makes working with these elements a bit easier along the way:

I won’t be able to test this myself as you’ll need to publish the changes, but hopefully that points you in the right direction :v:

Wow! Thank you very much. Watching your video now and will attempt changes. We will let you know how it goes. Incredible.

One quick question. Does it matter which browser we open the webflow editor in, to compose site? safari, chrome, firefox, etc…thank you. Still watching the video speechless.

I personally use Chrome for development (as this was the first browser support as far as I know) but you should be able to use Safari/Firefox as an alternative.

Good luck on getting the fixes implemented and feel free to reach out if you have any questions!