Streaming live at 10am (PST)

Why is my site is scrolling to the right?

Hey, I have run into two problems with my site.
First of, the site allows to scroll slightly to the right side. Even though there is no content. I noticed, the width is about the size of the scollbar on the right.

My second problem is the site not looking as i should on Firefox. The Headlines and animations are slightly missplaced.

Here is a link for opening the site on a browser: https://webflow-test-hacking4-407-7fc369acbdb81.webflow.io/

I’d be very grateful for some ideas on whats causing and how to fix there problems.


Here is my public share link: https://preview.webflow.com/preview/webflow-test-hacking4-407-7fc369acbdb81?utm_medium=preview_link&utm_source=designer&utm_content=webflow-test-hacking4-407-7fc369acbdb81&preview=f0fdc24036cd07399302bec4e5c5b31e&mode=preview

Hello @PhilMoll,

For the right scrolling, did you mean on mobile? because I only experience side scrolling on you mobile portrait break point, the reason it is doing that is because your div block 14 has 490px of width, change that value to auto and that will fix the side scrolling. As for the site not looking good on Firefox, could you be more specific? what headlines and what animations?

No i mean on the desktop version, but thank you for the tip when i get to designing the mobile version. I you open the Link on (at least crome) the side allows to scroll slighly to the right (Picture Included)

Regarding the Firefox Problem: The Healdines an the Opener animation are positioned wrong on Firefox.

Hello @PhilMoll,

I have been using chrome and safari and i don’t get that a side scroll at all. Try to refresh your browser both chrome and firefox see if that solves your issue. Let me know how it goes.

A fellow mac user with scroll behaviour set to show only when in use :slight_smile: Make sure to set this in settings to always show or you will never catch these pesky horizontal scrolls!

@PhilMoll You have a lot of your elements with width of 100vw. Do not use 100vw - use 100%. So check every section and change that setting.

Thank you! I just changed all widths that were 100vw to % and it worked.

Good to know! You’re welcome!

1 Like